Esato

Forum > Sony Ericsson / Sony > Technical > K850i dead except for keypad lights

Author K850i dead except for keypad lights
touriga
Model not set
Joined: Apr 30, 2008
Posts: 3
PM
Posted: 2008-04-30 09:53
Reply with quoteEdit/Delete This PostPrint this post
My K850i went in to a frozen state without any provocation from me. Screen is black. Only life is vibrate on switch on and keyboard lights. Also blue ring around camera lens. Once on like this the only way to switch off is remove battery. Phone does not respond to any keystrokes or power switch. Tried every combination of SIM, Mem card battery in and out without success.
Connecting to PC results in phone being recognised as a new unknown flash device and PC installing generic software, but it does not appear as a drive so I have no access. Not recognised in SE Suite.
I have arranged for repair from my service provider, but before they collect the phone is there anything I can try or do to do a "hard reset" or in order to get my data off the phone before handing it over?
I have searched esato and the web for hard reset info, but the only sensible generic answer I found was someone suggesting shorting out the terminals of the internal battery. I don't want to go there as it would involve dismantling the phone and it is still under warranty.
Any other ideas? [addsig]
dentoters07
Xperia X10 White
Joined: Jan 15, 2008
Posts: 285
From: 14 35' N, 121 0' E
PM
Posted: 2008-04-30 11:14
Reply with quoteEdit/Delete This PostPrint this post
Check this out..

http://www.esato.com/board/viewtopic.php?topic=157121

good luck!
totalgsm
W910 Black
Joined: Jan 12, 2007
Posts: > 500
From: totalgsm.org
PM, WWW
Posted: 2008-04-30 19:49
Reply with quoteEdit/Delete This PostPrint this post
Flash MAIN
Visit www.totalgsm.org for Remote and Instant unlocking and Debranding services for all Sony Ericsson Phones. Visit forum www.totalgsm.org/forum
craigw1701
Model not set
Joined: May 13, 2008
Posts: 2
PM
Posted: 2008-05-13 10:06
Reply with quoteEdit/Delete This PostPrint this post
My phone just did the exact same last night, and it wont work.
I've tried leaving the battery out over night, charging it, connecting to the PC, doing a firmware updated (failed on sending the update to the phone although it did recognise the firmware was up to date) don't really know what to do now. Don't really want to send my phone away for repairs because i'm moving house in a week and don't know where to yet

Anyway any help would be awesome, please :S

thanks
totalgsm
W910 Black
Joined: Jan 12, 2007
Posts: > 500
From: totalgsm.org
PM, WWW
Posted: 2008-05-13 10:51
Reply with quoteEdit/Delete This PostPrint this post

On 2008-05-13 10:06:52, craigw1701 wrote:
My phone just did the exact same last night, and it wont work.
I've tried leaving the battery out over night, charging it, connecting to the PC, doing a firmware updated (failed on sending the update to the phone although it did recognise the firmware was up to date) don't really know what to do now. Don't really want to send my phone away for repairs because i'm moving house in a week and don't know where to yet

Anyway any help would be awesome, please :S

thanks


Hi

Did you flash it with Main file?
Visit www.totalgsm.org for Remote and Instant unlocking and Debranding services for all Sony Ericsson Phones. Visit forum www.totalgsm.org/forum
craigw1701
Model not set
Joined: May 13, 2008
Posts: 2
PM
Posted: 2008-05-13 11:28
Reply with quoteEdit/Delete This PostPrint this post
Hey,

I just tried but i really don't know what i'm doing. I used XS++ and it said "phone unsupported" even though it said that it "has limited support" for my phone.

I am on the 3 Network and i don't think the XS++ had the firmware i needed, but i managed to find "K850i_1200-5441_HutchWorld_R1DA039_Red52" which i think is the correct firmware. But still didn't work. THen i tried D-Client but that seams to want to charge me so i dunno.
Any advice?
Cheers
touriga
Model not set
Joined: Apr 30, 2008
Posts: 3
PM
Posted: 2008-05-13 13:26
Reply with quoteEdit/Delete This PostPrint this post
After spending a few hours (actually many!) seeing if there was any way I could at least extract data off the phone, I sent it in to my service provider for repair.

They sent me a new phone back saying the old one was unrepairable.

Good luck to the rest of you.
totalgsm
W910 Black
Joined: Jan 12, 2007
Posts: > 500
From: totalgsm.org
PM, WWW
Posted: 2008-05-13 18:10
Reply with quoteEdit/Delete This PostPrint this post

On 2008-05-13 11:28:24, craigw1701 wrote:
Hey,

I just tried but i really don't know what i'm doing. I used XS++ and it said "phone unsupported" even though it said that it "has limited support" for my phone.

I am on the 3 Network and i don't think the XS++ had the firmware i needed, but i managed to find "K850i_1200-5441_HutchWorld_R1DA039_Red52" which i think is the correct firmware. But still didn't work. THen i tried D-Client but that seams to want to charge me so i dunno.
Any advice?
Cheers


Hi

XS does not support DB3150 phone which includes the K850i.
So if you want to use any remote tool you will have to buy credits.
Visit www.totalgsm.org for Remote and Instant unlocking and Debranding services for all Sony Ericsson Phones. Visit forum www.totalgsm.org/forum
Killfr3nzy
T230
Joined: Mar 08, 2008
Posts: > 500
From: Arabia and Hollanda
PM
Posted: 2008-05-13 21:05
Reply with quoteEdit/Delete This PostPrint this post
@craigw1701;

Like they said, the k850 isnt supported by XS (yet). So there goes your free-flashing option.

You'll have to flash it at Kulankendi or Wotanserver, but it isnt for free!


good luck


leorick
Model not set
Joined: Apr 25, 2009
Posts: 1
PM, WWW
Posted: 2009-04-25 17:16
Reply with quoteEdit/Delete This PostPrint this post
Screen is black. Only life is vibrate on switch on and keyboard lights. Also blue ring around camera lens. Once on like this the only way to switch off is remove battery. Phone does not respond to any keystrokes or power switch.


I'm facing the same problem too, and when I google for it, this page return on my search result. I give a try with "Update Service Application" and it works!

http://www.sonyericsson.com/cws/support/phones/topic/updateserviceapplication/k850i

Thanks a lot guys!
pigboy306
Model not set
Joined: Jun 30, 2008
Posts: 2
PM
Posted: 2009-09-07 18:32
Reply with quoteEdit/Delete This PostPrint this post
This worked for me aswell
adhgklk
C905 Silver
Joined: Feb 23, 2009
Posts: 483
From: iForo.DO
PM
Posted: 2009-09-10 07:07
Reply with quoteEdit/Delete This PostPrint this post
this problem is called Blue Ring of Dead, i think so...
EMW UNRATED

Access the forum with a mobile phone via esato.mobi